>
 
 
DBOldVersionError
Python 2.4.1
/usr/local/bin/python

A problem occurred while running a Python script. Here is the sequence of function calls leading up to the error, with the most recent (innermost) call last.

/home1/kenial/public_html/MoinMoin/cgimain.py in run(_cgiform=<class cgi.FieldStorage>)
  171         try:
  172             from MoinMoin.support import cgitb
  173             cgitb.handler()
       cgitb = <module 'MoinMoin.support.cgitb' from '/home1/kenial/public_html/MoinMoin/support/cgitb.py'>, handler = <function execute>
  174         except:
  175             cgi.print_exception()

/home1/kenial/public_html/MoinMoin/action/SpellCheck.py in execute(pagename='RecentMusics', form=FieldStorage(None, None, [MiniFieldStorage('action', 'SpellCheck')]))
   94     cachename = os.path.join(config.data_dir, 'dict.cache')
   95     if dbhash and os.path.exists(cachename):
   96         wordsdict = dbhash.open(cachename, "r")
       wordsdict = undefined, dbhash = <module 'dbhash' from '/usr/local/lib/python2.4/dbhash.pyo'>, global open = undefined, cachename = '/home1/kenial/public_html/WiKiDaTa/dict.cache'
   97     else:
   98         util.clock.start('dict.cache')

/usr/local/lib/python2.4/dbhash.py in open(file='/home1/kenial/public_html/WiKiDaTa/dict.cache', flag='r', mode=438)
   12 
   13 error = bsddb.error                     # Exported for anydbm
   14 
   15 def open(file, flag = 'r', mode=0666):
   16     return bsddb.hashopen(file, flag, mode)
       global bsddb = <module 'bsddb' from '/usr/local/lib/python2.4/bsddb/__init__.pyo'>, global hashopen = undefined, file = '/home1/kenial/public_html/WiKiDaTa/dict.cache', flag = 'r', mode = 438

/usr/local/lib/python2.4/bsddb/__init__.py in hashopen(file='/home1/kenial/public_html/WiKiDaTa/dict.cache', flag='r', mode=438, pgsize=None, ffactor=None, nelem=None, cachesize=None, lorder=None, hflags=0)
  291     if ffactor is not None:   d.set_h_ffactor(ffactor)
  292     if nelem is not None:     d.set_h_nelem(nelem)
  293     d.open(file, db.DB_HASH, flags, mode)
       d = <DB object>, global open = undefined, file = '/home1/kenial/public_html/WiKiDaTa/dict.cache', global db = <module '_bsddb' from '/usr/local/lib/python2.4/lib-dynload/_bsddb.so'>, global DB_HASH = undefined, flags = 80, mode = 438
  294     return _DBWithCursor(d)
  295 

DBOldVersionError: (-30990, 'DB_OLDVERSION: Database requires a version upgrade -- /home1/kenial/public_html/WiKiDaTa/dict.cache: hash version 5 requires a version upgrade')
      __doc__ = None
      __getitem__ = <bound method DBOldVersionError.__getitem__ of <bsddb._db.DBOldVersionError instance at 0x403b5eec>>
      __init__ = <bound method DBOldVersionError.__init__ of <bsddb._db.DBOldVersionError instance at 0x403b5eec>>
      __module__ = 'bsddb._db'
      __str__ = <bound method DBOldVersionError.__str__ of <bsddb._db.DBOldVersionError instance at 0x403b5eec>>
      args = (-30990, 'DB_OLDVERSION: Database requires a version upgr...cache: hash version 5 requires a version upgrade')